[Gretl-devel] Compiling Gretl on Snow Leopard

Allin Cottrell cottrell at wfu.edu
Sun Sep 6 09:55:35 EDT 2009


On Sun, 6 Sep 2009, Allin Cottrell wrote:

> You could try this experiment: go to
> /Library/Frameworks/GTK+.framework/Resources/lib
> and (probably after backing them up) delete all the *.la files in
> that directory.  Also (if necessary) track down and delete any .la
> files in other directories from which libraries are pulled into
> the gretl build (in my case that would include /usr/local/lib).
>
> Then try running gretl's configure script again and see if make
> works.

I can't test on 10.6, but I tried a related experiment on 10.4.11.

cd /Library/Frameworks/GTK+.framework
tar cvfz ~/la.tgz `find . -name "*.la"`
sudo find . -name "*.la" | xargs rm

Then I went to the gretl source and did

./configure <options>
make clean
make

This worked OK. (The "make clean" step was required, to flush out
references to the GTK+ .la files.)

Allin.


More information about the Gretl-devel mailing list