[Gretl-users] fcast arch bug?

Chris quilley at gmail.com
Wed Jun 13 16:07:56 EDT 2007


when I run the arch command I get an arch model returned and can see that it
is significant. Furthermore, when I run the arch command through the gui I
get the same model returned and I can estimate using fcasterr through the
gui to my hearts content. I'm not at the computer where I am running the
model right now, but when I am I will try and get you some output.

Chris

On 6/13/07, Allin Cottrell <cottrell at wfu.edu> wrote:
>
> On Tue, 12 Jun 2007, Chris wrote:
>
> > When I try to use fcast after an arch command I get the error
> >
> > ? fcast  fit2 --dynamic
> > Can't do this: no model has been estimated yet
> >
> > but when I replace the "arch 24" with "ols" the fcast command works
> fine. Is
> > this a bug or am I missing something?
>
> The arch command is a bit unusual (this should be probably be
> changed): it's a test, plus ARCH estimation _if_ the test if
> significant.  I suspect that in the case you're talking about the
> ARCH effect is not significant, so no ARCH model is actually
> returned.
>
> Allin.
>
> _______________________________________________
> Gretl-users mailing list
> Gretl-users at lists.wfu.edu
> http://lists.wfu.edu/mailman/listinfo/gretl-users
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.wfu.edu/pipermail/gretl-users/attachments/20070613/c7fe09dd/attachment.htm


More information about the Gretl-users mailing list