[Gretl-users] fcast arch bug?

Chris quilley at gmail.com
Sat Jun 16 11:57:01 EDT 2007


I finally made it to the computer where I'm running the regressions. When I
run an OLS regression on the model I'm testing and run the arch test I get
this output:


Test for ARCH of order 24

      PARAMETER       ESTIMATE          STDERROR      T STAT   P-VALUE

  alpha(0)              2.08514E+06 515100             4.048   0.00005 ***
  alpha(1)              0.938152         0.0247825    37.855  <0.00001 ***
  alpha(2)             -0.0826077        0.0339689    -2.432   0.01513 **
  alpha(3)             -0.0205300        0.0340354    -0.603   0.54646
  alpha(4)             -0.0667144        0.0340145    -1.961   0.05001 *
  alpha(5)              0.0127966        0.0339762     0.377   0.70650
  alpha(6)             -0.0590282        0.0337789    -1.747   0.08074 *
  alpha(7)              0.0648604        0.0338031     1.919   0.05519 *
  alpha(8)              0.0209728        0.0338221     0.620   0.53528
  alpha(9)             -0.0761478        0.0337007    -2.260   0.02398 **
  alpha(10)             0.0724101        0.0336583     2.151   0.03160 **
  alpha(11)            -0.0280495        0.0337054    -0.832   0.40542
  alpha(12)             0.0116758        0.0337173     0.346   0.72917
  alpha(13)            -0.00739561       0.0337165    -0.219   0.82641
  alpha(14)             0.0106318        0.0337551     0.315   0.75283
  alpha(15)             0.103602         0.0337038     3.074   0.00215 ***
  alpha(16)            -0.116552         0.0337181    -3.457   0.00056 ***
  alpha(17)             0.00503461       0.0338357     0.149   0.88173
  alpha(18)            -0.0265224        0.0337809    -0.785   0.43249
  alpha(19)             0.141321         0.0337470     4.188   0.00003 ***
  alpha(20)            -0.0856709        0.0339276    -2.525   0.01166 **
  alpha(21)             0.0519347        0.0339545     1.530   0.12633
  alpha(22)            -0.0276832        0.0339709    -0.815   0.41524
  alpha(23)             0.0396563        0.0339167     1.169   0.24248
  alpha(24)            -0.00949085       0.0246846    -0.384   0.70067

  Null hypothesis: no ARCH effect is present
  Test statistic: TR^2 = 1182.98
  with p-value = P(Chi-Square(24) > 1182.98) = 1.04224e-234



The p-value is essentially zero, so I should be rejecting the null
hypothesis and there should be a model availalbe for forecasting when I run
the arch command then correct?

Thanks,

Chris



On 6/13/07, Chris <quilley at gmail.com> wrote:
>
> when I run the arch command I get an arch model returned and can see that
> it is significant. Furthermore, when I run the arch command through the gui
> I get the same model returned and I can estimate using fcasterr through the
> gui to my hearts content. I'm not at the computer where I am running the
> model right now, but when I am I will try and get you some output.
>
> Chris
>
> On 6/13/07, Allin Cottrell <cottrell at wfu.edu> wrote:
> >
> > On Tue, 12 Jun 2007, Chris wrote:
> >
> > > When I try to use fcast after an arch command I get the error
> > >
> > > ? fcast  fit2 --dynamic
> > > Can't do this: no model has been estimated yet
> > >
> > > but when I replace the "arch 24" with "ols" the fcast command works
> > fine. Is
> > > this a bug or am I missing something?
> >
> > The arch command is a bit unusual (this should be probably be
> > changed): it's a test, plus ARCH estimation _if_ the test if
> > significant.  I suspect that in the case you're talking about the
> > ARCH effect is not significant, so no ARCH model is actually
> > returned.
> >
> > Allin.
> >
> > _______________________________________________
> > Gretl-users mailing list
> > Gretl-users at lists.wfu.edu
> > http://lists.wfu.edu/mailman/listinfo/gretl-users
> >
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.wfu.edu/pipermail/gretl-users/attachments/20070616/6a88ac61/attachment.htm


More information about the Gretl-users mailing list