[Gretl-users] GTK libraries

Riccardo (Jack) Lucchetti r.lucchetti at univpm.it
Tue Nov 3 15:30:38 EST 2009


On Tue, 3 Nov 2009, Allin Cottrell wrote:

>
> On Tue, 3 Nov 2009, Gordon Hughes wrote:
>
>> For future reference, it might be helpful to add a note to the text
>> on Gretl's dependencies advising users to install the -dev variants
>> of the libraries from the relevant repository.
>
> See Appendix C, "Building gretl", in the Gretl User's Guide.

People using apt-based distros, such as Debian and Ubuntu, may find the 
following command useful:

apt-get build-dep gretl

This will install all the "-dev" packages needed to build the version of 
gretl for your distro version (for example, ubuntu 9.10 has gretl 1.8.1, 
while debian testing has 1.8.5). However, the insertion of additional 
dependencies for building gretl is a relatively rare event, and in most 
cases you ought to be fine with that.


Riccardo (Jack) Lucchetti
Dipartimento di Economia
Università Politecnica delle Marche

r.lucchetti at univpm.it
http://www.econ.univpm.it/lucchetti


More information about the Gretl-users mailing list