[Gretl-users] Compiling Gretl on RHEL 5

Allin Cottrell cottrell at wfu.edu
Wed Sep 10 11:14:09 EDT 2014


On Wed, 10 Sep 2014, Charles Gagnon wrote:

> I support gretl for a group who uses it, so I don't use it myself. But I'm
> running into issues compiling and installing.
>
> I'm trying to deploy the latest gretl-1.9.91 on a RHEL 5.9 box.
>
> The configure script complains that:
>
> Please install glib-2.0 >= 2.12.0 and then reconfigure gretl.
> glib-2.0 is available from http://www.gtk.org/
>
> Yet I have glib 2.12.3 installed. I checked in the config.log and it seems
> like to be looking for > 2.14 so I'm confused:
>
> configure:17635: $PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.14.0"
> Requested 'glib-2.0 >= 2.14.0' but version of GLib is 2.12.3
> configure:17652: $PKG_CONFIG --exists --print-errors "glib-2.0 >= 2.14.0"
> Requested 'glib-2.0 >= 2.14.0' but version of GLib is 2.12.3
> Requested 'glib-2.0 >= 2.14.0' but version of GLib is 2.12.3
>
> I would just upgrade glib but it seems involved since the repository does
> not have it available for RHEL 5.

Thanks for the report. We've in fact required glib-2.0 >= 2.14.0 for quite 
some time now, but we forgot to update the text that appears if the glib 
requirement is not satisfied. (This was fixed in CVS on August 1, shortly 
after the 1.9.91 release.)

I guess we can double-check if we really need glib functionality that was 
added between versions 2.12 and 2.14. I think the answer is Yes but we can 
see if there may be a workaround. However, glib 2.14 was released seven 
years ago, so it doesn't seem an outlandish requirement!

Allin Cottrell


More information about the Gretl-users mailing list